Appliance Repair Blog
Thoughts and commentary about appliance repair topics including common failures and repairs, plus links to frequently used parts, industry news, along with information to help you better understand your appliances. Resources available for the technical professional and the do-it-yourselfer. Over 650 Posts

Kitchenaid Refrigerator not dispensing ice


Model #KSRS25RVBL00icon, this side by side refrigeratoricon had been working just fine for the customer with the exception of the ice dispenser. When the ice paddle was pressed to get some ice, the customer could hear the motor running, but no ice was coming out. It didn’t seem to matter if cubed or crushed was selected, the results were the same. The customer was left using the manual method of dispensing ice, reaching into the ice bucket.

Most ice dispensers use a motor and auger assembly to draw ice from the storage bucket to the ice chute. The augers act like a corkscrew drawing ice toward the chute and will be connected to the motor by some type of coupler. Depending on the design, some augers will dispense cubed ice when rotated one way, while dispensing crushed ice in the other direction. For this reason, the motors and drive systems in these units must be able to provide some serious torque while in operation but not enough to damage any of the refrigerator parts.

The ice bucket on this model is referred to as in the door ice because it is mounted vertically inside the freezer door. It will rotate one way for cubed and the other for crushed, and is connected to a drive motor via a spring loaded motor coupler. The motor is accessible by removing a cover on the inside door cover, while the coupler and shaft can be removed by first taking the bucket off the mount and removing a couple of screws. This particular design works very well, but can prove troublesome if the two halves of the coupler cannot make a good connection when the motor is in operation.

Because of the symptom described by the customer, I figured either the auger motor had failed internally, or this was simply a coupler problem. When I arrived, I removed the ice bucket and found the lower coupler packed with ice. This happens when people frequently use crushed ice and the small ice chips will melt during defrost or when the door is opened. The water from the ice collects in the bottom coupler channel becuase of a seal used to prevent water from getting to the motor. When the water freezes again, it will prevent the coupler halves from connecting. Sometimes the ice will grind away and the coupler will reengage, while other times, the two halves never connect which results in the dispenser auger not working.

I removed the two screws holding the lower coupler in place and carefully removed the components as they are spring loaded. Running the coupler under warm water, I looked at the edges of the teeth and they appeared to be in good shape. With everything cleared of ice and dry, I put it all back together and installed the ice bucket back in place. The coupler halves snapped together and the auger began to turn as it should.

This turned out to be an easy call, but if you look at the couplers and find any damage, it is best to replace the topicon and bottomicon halves to ensure a good fit while in use.
Just a note, the design of these couplers has been changed somewhere around 2008. The new design is less likely to strip and is less susceptible to ice buildup. This is important to know because the parts are not interchangeable.

Leave a Reply